Gestionnaire MultiPHP et Sélectionner une version de PHP

Vous trouverez deux caractéristiques similaires à l'intérieur de tous les comptes cPanel : Gestionnaire MultiPHP et Sélectionner une version de PHP.

Sélectionner une version de PHP

La fonction dans votre cPanel > Sélectionner une version de PHP* est l'outil par défaut utilisé pour choisir la version de PHP pour votre compte. Le paramètre choisi dans cette zone s'appliquera par défaut à l'ensemble du compte, y compris les sites web, les cron jobs et la ligne de commande. Avec cet outil, vous pouvez choisir la version de PHP et définir de nombreuses options pour cette version, telles que upload_max_filesize, post_max_size, et memory_limit.

Gestionnaire MultiPHP

La fonction de votre cPanel > Gestionnaire MultiPHP vous permettra de définir une version PHP par domaine ou par dossier pour votre compte. Les paramètres choisis dans cette zone du cPanel remplaceront la version choisie dans la zone Sélectionner une version de PHP .

Pour la plupart des versions de PHP, vous trouverez deux options dans l'outil Gestionnaire MultiPHP. Par exemple, pour la version 7.2 de PHP, vous trouverez ces versions :
alt-php72 et ea-php72.

alt-php VS ea-php

alt-php est la version de PHP fournie par CloudLinux et qui est sélectionnable par la fonction Sélectionner une version de PHP de votre cPanel. Les paramètres de l'Éditeur MultiPHP ne s'appliquent pas aux versions de PHP qui commencent par alt-php, et toutes ses versions permettent le contrôle des extensions PHP.
Pour plus d'informations, veuillez lire notre article sur la procédure à suivre pour activer / désactiver les extensions PHP.
Les versions alt-php actuellement disponibles dans nos serveurs sont les suivantes : 4.4, 5.1, 5.2, 5.3, 5.4, 5.5, 5.6, 7.0, 7.1, 7.2, 7.3, 7.4.

ea-php est la version de PHP qui est fournie par cPanel et qui est disponible dans la fonction Gestionnaire MultiPHP. Les paramètres de l'Éditeur MultiPHP s'appliqueront à toute version de PHP commençant par ea-php. Aucun paramètre de la fonction Sélectionner une version de PHP de votre cPanel ne s'appliquera à une version ea-php.
Les versions ea-php actuellement disponibles dans nos serveurs sont les suivantes : 5.6, 7.0, 7.1, 7.2, 7.3

Nous vous recommandons de n'utiliser que la fonction Sélectionner une version de PHP, sauf si vous avez besoin d'une version spécifique de PHP pour un site ou dossier spécifique.

Changer la version de PHP

Pour changer la version de PHP utilisée pour votre compte, suivez ces étapes :

Connectez-vous au cPanel

Dans la section LOGICIEL, cliquez sur Sélectionner une version PHP.



cPanel affiche la version actuelle de PHP.

Dans le menu déroulant, choisissez la version PHP que vous souhaitez pour votre site.

Cliquez sur le bouton Set as current.

Le changement sera appliqué instantanément.


Passer de alt-php à ea-php

Connectez-vous au cPanel

Dans la section LOGICIEL, cliquez sur Gestionnaire MultiPHP.



Cochez le domaine ou le sous-domaine que vous souhaitez modifier.



Dans le menu déroulant, choisissez une version** alt-php**.





Cliquez sur Appliquer


Le changement sera appliqué instantanément.
Cet article a-t-il répondu à vos questions ?
Annuler
Merci !